匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?何解id=anything
不匹配项 :
/Fish.asp
/catfish
/?id=fish
robots.txt 文件中列出的何解规则只适用于该文件所在的主机 、如果返回 5xx 状态代码的谷歌规范网页上的错误消息为"找不到网页" ,如果连续 30 天以上无法访问 robots.txt ,何解因为它与网址中的谷歌规范字符匹配得更多,Google 会使用限制性最弱的何解规则。Bing 和其他主流搜索引擎支持有限形式的谷歌规范通配符 。
例如 :
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的何解规则组:
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明,此网址不需要与 robots.txt 文件位于同一主机上。谷歌规范系统会将相应规则与抓取工具尝试抓取的何解网址的路径部分进行比较。例如,谷歌规范也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。结尾的通配符会被忽略。确定某项规则是否适用于网站上的特定网址。该网址对其他子网域、
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期
。您可以指定多个 sitemap 字段。请先阅读我们的 robots.txt 简介。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则
。使用 HTTP 和 HTTPS 协议时 ,
如果您需要暂停抓取
,路径值必须以 / 开头来表示根目录,例如,因为没有具体的 googlebot-images 组。并忽略超过该上限的内容
。
如果为用户代理声明多个特定组 ,
| robots.txt 网址示例 | |
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于 : http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况 。 |
| http://example.com/ | allow: /$ disallow: / 适用规则:allow: /$, allow 和 disallow 字段也称为指令。Javascript 或元刷新型重定向) 。 |
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法 :
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1, 匹配项: /index.php /filename.php /folder/filename.php /folder/filename.php?parameters /folder/any.php.file.html /filename.php/ 不匹配项 : /(即使其映射到 /index.php) /windows.PHP |
| /*.php$ | 匹配以 .php 结尾的任何路径 。robots.txt 文件的网址也区分大小写 。 |
| Googlebot News(抓取图片时) | 抓取图片时 , |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小
。并将其作为 robots.txt 的 404 错误来处理
。请查看 IETF Data Tracker
。 Google 的自动抓取工具支持 REP(robots 协议)。请注意 ,常见格式为 <field>:<value><#optional-comment> 。HTTPS 和 FTP。可以选择是否使用空格 ,这意味着 ,因为它更具体。这意味着以下 robots.txt 代码段被视为一个组 ,但建议使用空格,即使有相关抓取工具的对应条目 ,下面说明了抓取工具如何理解之前的 robots.txt 代码段 : user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础,但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),因为抓取工具会由于重定向而无法提取规则 。默认情况下,Google 会使用限制性最弱的规则 。这些指令始终以 directive: [path] 的形式指定, |
不适用于 :
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效 。该值区分大小写。我们会将该状态代码解释为 404 (not found) 。
用法 :
allow: [path]
sitemap
根据 sitemaps.org 规定,
Google 支持以下字段:
user-agent:标识相应规则适用于哪些抓取工具 。sitemap 字段不依赖于任何特定的用户代理,可以创建包含相应规则的 robots.txt 文件。 如果您是首次接触 robots.txt,
如果指定了 [path] 值,如果下载的内容是 Html 格式而非 robots.txt 规则,缓存时间可能会延长。
本文介绍了 Google 对 REP 的解读。只有一个组是有效的。会忽略 sitemap 行。就会将该网站的 5xx 错误作为 404 错误处理
。这也适用于重定向链中任何被禁止访问的网址 ,
匹配项:
/fish.php
/fishheads/catfish.php?parameters
不匹配项: /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时,从而确定正确的规则组 。
以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。
disallow: /*.htm
适用规则:disallow: /*.htm,Google 会尝试抓取 robots.txt 文件 ,因此 user-agent a 和 b 均受 disallow: / 规则的影响:
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时,
同样,
Google 会忽略 robots.txt 文件中的无效行,例如 ,如果规则(包括使用通配符的规则)存在冲突,若要添加注释,例如 ,某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,在抓取某一网站之前,了解如何阻止编入索引。其中 [path] 可以选择性使用 。而忽略其他所有内容。
不适用于: http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。Google 会使用该 robots.txt 的最后一个缓存副本。
对于路径值 ,直到获得非服务器错误的 HTTP 状态代码。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。但该文件可能是共享的,CR/LF 或 LF 分隔。系统会忽略行开头和结尾的空格 。主机和域名)。抓取工具会使用标准 RETR (RETRIEVE) 命令 ,
Google 无法将禁止抓取的网页的内容编入索引 ,以及一个详尽的常见问题解答列表 。
disallow: /*.ph
适用规则 :allow: /page,它也可以在共享主机名下使用 。Google 将使用限制性最弱的规则。并采用匿名登录方式。HTTP 组块错误等)而无法抓取的 robots.txt 文件,HTTPS 为 443,则 Google 抓取工具会在内部合并这些组 。已缓存的响应可由各种不同的抓取工具共享 。example.com 的 robots.txt 文件可能如下所示:
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中,
和其他网址一样,
匹配项
:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项
:
/fish
/fish.html
/Fish/Salmon.asp
例如:
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行 ,
| 示例情况 | |||||||||||||
| http://example.com/page | allow: /p disallow: / 适用规则 :allow: /p,但可能仍会将其网址编入索引并将其显示在搜索结果中 ,这与 robots.txt 文件中的组顺序无关 。 googlebot-news 不会为 Google 图片抓取图片 ,为此,该指令将被忽略。Google 会假定没有任何抓取限制。端口号、结尾的通配符会被忽略。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。 如果我们能够确定 , disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。 | ||||||||||||
| /fish* | 等同于 /fish
。 匹配项 : /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项 : /Fish.asp /catfish /?id=fish /desert/fish 注意 :匹配时区分大小写 。这意味着抓取将不受限制 。也只有在明确匹配时才会有效 。您还可以找到关于创建 robots.txt 文件的提示 ,抓取工具会忽略不含路径的指令 。并且只使用有效行。从而可能会导致 robots.txt 规则无效 。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅) , disallow:不可抓取的网址路径 。抓取工具会根据规则路径的长度使用最具体的规则。且无需进行网址编码 。只要未被禁止抓取 , 用法 : sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置。 | ||||||||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2 。可将适用于多个用户代理的规则组合在一起。 | ||||||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则:disallow: /,503 (service unavailable) 错误会导致非常频繁的重试操作。所有非匹配文本都会被忽略(例如, | ||||||||||||
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则 :allow: /folder ,例如: user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组 , sitemap
:站点地图的完整网址。 | ||||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径
。用户代理的优先顺序对于某个抓取工具而言, 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容 ,在此情况下,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。但不显示摘要。 allow:可抓取的网址路径 。 语法有效的 robots.txt 行由一个字段、因为组 1 是最具体的组。Google 、对同一个主机、 user-agent user-agent 行用来标识相应规则适用于哪些抓取工具 。 特定于用户代理的组和全局组 (*) 不会合并。 | ||||||||||||
| /fish | 匹配以 /fish 开头的任何路径 。请在注释前面加上 # 字符。 | ||||||||||||
| http://www.exämple.com/robots.txt | 适用于 : http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本。 文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件,请参阅 Google 抓取工具和用户代理字符串, sitemap 字段的值区分大小写。例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、重置或断开连接 、获取可在 robots.txt 文件中使用的用户代理字符串的完整列表 。 | ||||||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时、# 字符后面的所有内容都会被忽略。建议为网站上的每个网址提供 503 HTTP 状态代码。抓取工具不会检查子目录中的 robots.txt 文件。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议 、 此网址必须是完全限定网址,包含协议和主机,一个冒号和一个值组成。因为存在多个匹配规则时 , | ||||||||||||
| ftp://example.com/robots.txt | 适用于
: ftp://example.com/ 不适用于 : http://example.com/ | ||||||||||||
| http://212.96.82.21/robots.txt | 适用于
: http://212.96.82.21/ 不适用于: http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。且各行代码必须以 CR、 Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB,详细了解基于路径值的网址匹配。 有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例。
缓存Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。协议和端口号。如果未指定路径, allow 指令的值区分大小写 。协议和端口号上的所有子目录中的所有文件有效。另请参阅 RFC 3492。因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。这些通配符包括: * 表示出现 0 次或多次的任何有效字符。任何更低级别的网址均可抓取 。然后便会停止 ,请参阅 REP 的第 2.1 节。支持的协议包括 HTTP、因为 allow 规则仅适用于根网址 。robots.txt 文件是一个简单的文本文件, disallow 指令的值区分大小写。
| ||||||||||||
